Acronaut Diskussions Forum Home

Freies User Forum für

ADOBE® ACROBAT®

Navigation
Nicht angemeldet

Login | Registrieren 

  

Suche

Erweiterte Suche

Newsletter

Mitgliederliste

Kalender

Moderatoren/Partner

Hilfe

Banner

Kontakt/Impressum
 
Tabellenfelder löschen
 Moderiert von: acronaut Produkt: Adobe LiveCycle Designer Version nicht definiert  

Neue Diskussion

Antworten

Drucken
VerfasserBericht
ringelnatz66
Member
 

Eintragen seit: 29 Aug 2011
Herkunft:  
Berichte: 5
Status:  Offline
 Geschrieben: 30 Aug 2016 13:47

Text übernehmen

Antworten
Ich versuche aus einer dynamischen Tabelle per Script alle Datenzellen einer bestimmten Spalte auf 0 zu setzen. Leider will mir das nicht gelingen. Habe das Formular mal angehängt. Es handelt sich z.B. um die Tabelle 6 und die Spalte "Nettobetrag". Ich könnte auch damit leben wenn man nur den gesamten Tabelleninhalt löschen könnte.

Jemand eine Idee oder Erfahrung

Viele Grüße

Michael

Anlage: 930503501_Test.pdf (3 Mal aufgenommen)

Andreas H.
Member
 

Eintragen seit: 13 Apr 2015
Herkunft:  
Berichte: 414
Status:  Offline
 Geschrieben: 31 Aug 2016 07:25

Text übernehmen

Antworten
Hallo Michael,

in Deiner Datei habe ich die Tabelle 6 nicht gefunden sollte es die statische Tabelle 10 sein? Dann habe ich hierzu ein Beispiel angehangen. Vieleicht hilft Dir das weiter. Hier lassen sich die Zellen einzeln ansprechen ohne Schleife.

Gruß
Andreas


Anlage: statischeTabelleSpalte2InhaltLoeschen.pdf (7 Mal aufgenommen)

ringelnatz66
Member
 

Eintragen seit: 29 Aug 2011
Herkunft:  
Berichte: 5
Status:  Offline
 Geschrieben: 31 Aug 2016 10:03

Text übernehmen

Antworten
Danke Andreas,

wie das in einer statischen Tabelle (ist ja nichts anderes als ein enzelnes Feld) funktioniert weiss. Mit geht es um die dynamische Tabelle wo ich ja noch nicht weiss wieviel Zeilen ich habe.

Übrigens ist die Tabelle6 schon da nur im Standard aus dem Layout ausgeblendet. In der Hirarchie siehst Du sie aber. Zum Testen einfach auf sichtbar stellen.

Gruß aus Mülheim

Michael

Andreas H.
Member
 

Eintragen seit: 13 Apr 2015
Herkunft:  
Berichte: 414
Status:  Offline
 Geschrieben: 31 Aug 2016 10:35

Text übernehmen

Antworten
Hallo Michael,

da habe ich nicht genau hingesehen. Denn über die CheckBox "weiteren Verwendungsnachweis einblenden" wird nichts eingeblendet!?

Hier wird die Tabelle 6 zurückgesetzt egal wie viele Zeilen per Plus Button hinzugefügt sind.

Gruß
Andreas

Anlage: 930503501_Test_a.pdf (4 Mal aufgenommen)

Andreas H.
Member
 

Eintragen seit: 13 Apr 2015
Herkunft:  
Berichte: 414
Status:  Offline
 Geschrieben: 31 Aug 2016 10:43

Text übernehmen

Antworten
... so, nun habe ich neugierig auch mal die Checkbox kontrolliert und sieha da:


OSPDMS.Nachweis.T6.Platz5.Kontrollkästchen6::click - (JavaScript, client)

Zeile1
...
...
...
Zeile16 oFields.item(i) = 0}

In Zeile 16 ist der Fehler aufgedeckt und Du hast was zu tun, aber da sind noch andere nicht funktionierende Sachen drin, nur mal so als INFO nebenbei.

Viel Erfolg

Gruß
Andreas


Andreas H.
Member
 

Eintragen seit: 13 Apr 2015
Herkunft:  
Berichte: 414
Status:  Offline
 Geschrieben: 31 Aug 2016 11:35

Text übernehmen

Antworten
Hallo Michael,

bevor Du die nächste Frage stellst, auch das geht, weil ich mich noch mal aufgerafft habe kannst Du nun auch nur die Spalte mit den "Nettobeträgen" löschen.

Wünsche erfüllt?

Gruß
Andreas

Anlage: 930503501_Test_b.pdf (12 Mal aufgenommen)

ringelnatz66
Member
 

Eintragen seit: 29 Aug 2011
Herkunft:  
Berichte: 5
Status:  Offline
 Geschrieben: 31 Aug 2016 12:40

Text übernehmen

Antworten
Funktioniert prima. Wieder was gelernt. Vielen Dank.

Gruß Michael

ringelnatz66
Member
 

Eintragen seit: 29 Aug 2011
Herkunft:  
Berichte: 5
Status:  Offline
 Geschrieben: 2 Sep 2016 09:13

Text übernehmen

Antworten

Letzte Änderung am 2 Sep 2016 09:14 von ringelnatz66


 Uhrzeit 03:21





Powered by WowBB 1.7 - Copyright © 2003-2006 Aycan Gulez
Seite erstellt in 0.1095 Sekunden (35% DB + 65% PHP). 15 verarbeitete Abfragen.